Client for Pirate Storm Issues - Post All Issues in This Section Only

Discussion in 'Questions & Bug Reports' started by Mavis_Vermilion, Nov 9, 2020.

Dear forum reader,

if you’d like to actively participate on the forum by joining discussions or starting your own threads or topics, please log into the game first. If you do not have a game account, you will need to register for one. We look forward to your next visit! CLICK HERE
Thread Status:
Not open for further replies.
  1. standeley

    standeley User

    same for me, and when i try with my other account, it works like its magic...
     
  2. Buchnát

    Buchnát User

    it works for me like this, first I enter the game through the browser and then the client works for me
     
  3. WaterWillow

    WaterWillow Team Leader Team Pirate Storm

    Are you sure the 64-Bit Launcher is the correct one for your system? Do you have any issues logging in from a browser?
     
  4. HELLBORE

    HELLBORE User

    Well Launcher still does not work for me. I dl'd both 32 and 64bit and both have same problem. It starts loading and can get through both log in screens but then it gets stuck in perpetual loading screen. Task manager says client not responding after that. I have to use the TM to shut it down. I do not get any error message. Am using Win10 and Google Chrome. My normal favorites shortcut also now acts this way and am forced to log into PS from BP website which I know wont last much longer.
     
  5. Newest version of the 64-bit client still crashes randomly. I updated last evening (12/4/2020), and this morning had two crashes in quick succession. This may be related to another member of my household waking up and beginning to use our internet connection, as I had no problems before she got up.

    Still, the app needs to learn to share, and quickly.
     
  6. Jolly-Bonesjack

    Jolly-Bonesjack Board Administrator Team Pirate Storm

    Ahoy -DeadeyeDavey-

    Do you have any issues logging in from a browser and not having random crashes?


    Best Regards!
     
  7. Nope. Web browser works fine.
     
  8. HELLBORE

    HELLBORE User

    Browser still works for me too but is still flash based so expect it to stop working at end of month. Need the launchers to be working by then.
     
  9. perez_099

    perez_099 User

    Hello, I wanted to ask if you are making the launcher for mac.
     
    arch-567 likes this.
  10. WaterWillow

    WaterWillow Team Leader Team Pirate Storm

    Ahoy perez_099,

    There are no plans at this time to create a Launcher dedicated to the MacOS.

    Happy Sailing!
     
    perez_099 likes this.
  11. Damqn78

    Damqn78 User

    When i try to play form the launcher after i click play my screen becomes black and i can hear only the music from the game. I tried to click F5 and close programs running in the background but nothing fixed the problem. What i have to do to fix that
     
  12. Hello,
    I can't use the keyboard keys for items, but also for the captain's orders. I have to use the numeric keypad, which doesn't suit me.
    I reinstall the client but is doesn't work. I'm in 64 bit.
    How should I do it ?
     
  13. Jolly-Bonesjack

    Jolly-Bonesjack Board Administrator Team Pirate Storm

  14. Tried the launcher again, and the crashing problem hasn't reoccurred -- despite lots of Winter Event action. Coming back after the night, I found myself in "spinning wheel" land again on the launcher. Data point -- it seems to be related to the "daily ad". I logged off the launcher, logged into the browser and hit "Play". The ad came up and I got a "bar", and was able to log in. I logged out of the browser and back into the launcher, and was able to get a "bar" on the second try.

    Correction (Mon Evening): I spoke too soon on the crashing problem. Crashed 3 waves in on the pay event bonus map, and again in the middle of a z15 island invasion.
     
    Last edited: Dec 22, 2020
    arch-567 likes this.
  15. WaterWillow

    WaterWillow Team Leader Team Pirate Storm

    Ahoy -DeadeyeDavey-,

    There is an issue with getting past the Ad, especially on the US1 and LA1 Servers. These servers have a history of slow connection which results in players having longer delay in entering the game regardless of whether trying to connect through the Launcher or a Browser.

    Does your device meet all the requirements to run the Launcher? Are their multiple accounts connecting at the same time which may slow your internet speed and caused your game to crash? Do you have the most recent version of the Launcher? It may be necessary to close all open programs when running the Launcher. The ability to clean the cache in the Launcher is also available.

    upload_2020-12-22_9-53-19.png

    Happy Sailing!
     
  16. Thanks for the reply. My machine easily meets the requirements. My internet at home is 20Mb DSL, shared by two Pirate Storm players, my wife and myself, and my son, who doesn't play, but uses the internet for other things. All that's running on my machine is Chrome and the launcher. Kicking the other two off when I'm playing is not an option, nor is faster service.

    Will clearing cache get me past the Ad on the launcher? Last time I had to resort to the browser, which won't be an option in a week.
     
  17. WaterWillow

    WaterWillow Team Leader Team Pirate Storm

    Ahoy -DeadeyeDavey-,

    Getting past the ad is a tiresome process for many. The only option is to hit F5 and wait on the ad to load. The Development Team is working on the ad issue. But, there is still an entirely different obstacle that must be addressed as it relates to server connection issues with the US1 and LA1 Servers. These 2 servers were merged together some time ago and have experienced a slow connection since.

    Happy Sailing!
     
  18. Last time I never saw the Ad in the launcher. All I saw was the wheel. When I started on the Web Browser, the Ad came right up.
     
  19. zjarrm

    zjarrm User

    Hi everybody!
    The launcher doesn't work stuck on loading.
    Windows 8/ some times work sometime no
    Tried with:
    clearing cache / nothing
    disable antivirus / nothing
    install uninstall 32/64 (just to proofe) any time of installing uninstalling pc restart / and nothing.
    i don't know .....

    thank you in advance for all the help but this way i'm loosing the winter event
     
  20. I still have never gotten the "daily ad" to come up in the launcher. To get into the game after new day, I still need the web browser.

    Still crashing periodically. Trying to catch any info from Task Manager or "info" bar. When I kill the launcher after a crash it is sending data to MicroSoft.

    Another new day, no ad on launcher. I'll try a re-install tomorrow just in case.

    New wrinkle: I got into a state today where the "rings" around my ship indicating active Captain's Orders didn't show up. The buffs were still there, and the "Buf Removed" notices still showed, but no rings. Not sure if this is launcer related or not. My wife says I might be getting "small ship" rings that aren't always visible.

    Update 12/26/2020: Uninstalled, re-downloaded 64-bit launcher, re-installed. No crashes today so far. Launcher still doesn't even seem to be trying for "daily ad". Just long periods of "spinning wheel" after new day. If I log out of the launcher and log into the browser, I get an ad immediately, and a bar right after that (better than I usually have done with the browser, where it often takes several tries). Log out of the browser and into the launcher. The bar comes up first or second try, and I'm in.

    With 5 days to go, if it were me I'd disable the daily ad until you can fix it, or just give us a button on the launcher that only plays the ad and gives us credit for enduring it. After that, letting us log in. Just a thought.

    12/27/2020 9:30 AM PST - Alas, I spoke too soon. Launcher crashed while I was daily training in z21. At the time of the crash, I was in an empty section of sea, not actively shooting.
     
    Last edited: Dec 27, 2020
Thread Status:
Not open for further replies.

Share This Page